通达信cost函数源码,有谁能提供WINNER()函数的源代码

  Q1:有谁能提供WINNER()函数的源代码

描述:获利盘比例
类别:指标
参数:A为数组(变量)或常数
返回:返回数组
说明:计算获利盘比例,该函数仅对日线分析周期有效
示例:WINNER(CLOSE),表示以当前收市价卖出的获利盘比例,如返回0.2表示20%获利盘;
WINNER(10)表示10元价格的获利盘比例
WINNER与COST是正好相反的两个函数,前者由价格求获利盘比例,而后者由获利盘比例求得价格,灵活应用这两个函数,可以定量地进行成本分析计算。
COST,成本。WINNER,优胜者,获利。

  Q2:怎样引用通达信大盘函数写COST文本

COST成本分布函数只对个股有效,对大盘等指数类的不可使用。

  Q3:COST(10) 请问 我要使用用大智慧选股, 请问该怎么使用呀 帮我写下源码,

{买预警}
VARC:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3));
买:VARC;
{卖预警}
VARD:=(ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3));
卖:VARD;
注意:有未来函数!!!

  Q4:请帮我把这个副图公式修改成选股公式,并把里面的COST尽可能的修改掉未来函数,谢谢

DIF:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);
DEA:=REF(DIF,1)>13 AND REF(DIF,1)/DIF>1.23 AND CLOSE/REF(CLOSE,1)>1.03;
KOV:=IF(DEA AND REF(CLOSE,1)<=COST(5),28,0);
PIC:=IF(DEA AND REF(CLOSE,1)<=COST(5),18,0);
春暖花开:IF(DEA AND REF(CLOSE,1)<=COST(5),20,0);
说明一下,COST如果是引用昨天的数据,则不是未来函数,如果引用当天没收盘的数据,则可以看成是未来函数。好像CLOSE收盘价,H最高价,L最低价等等一样,没收盘前,CLOSE,最高价,最低价是不断变化的,收盘后,所有的值就固定下来了,这些都不算是未来函数。同理,COST也是一样的。
所以,这条公式只要不在盘中选股就没问题了,盘后可以放心用法它来选股。
附成本分布情况COST函数.
用法:
COST(10),表示10%获利盘的价格是多少,即有10%的持仓量在该价格以下,其余90%在该价格以上,为套牢盘
该函数仅对日线分析周期有效

  Q5:股票公式:有WINNER函数的指标公式是不是都没有效果了

超跌无效,把测量周期加长或者到周线上看也许会好点。

  Q6:没有办法选出月筹码获利比例小于50%的个股?因通达信函数 WINNER(C);仅对日线分析周期有效

http://www.yztz.com/?u=681031